招贤纳士
你的位置:【开元ky888棋牌游戏手机版免费下载手机网页登录】 > 招贤纳士 > 牛买选股公式源码编程思路及告成率回测数据
牛买选股公式源码编程思路及告成率回测数据
发布日期:2022-09-06 20:01    点击次数:132

​条件选股:牛买[日线]告成率测试

测试股票数:4554

共收回旗子灯号:11796告成旗子灯号:8356失利旗子灯号:3176未实现旗子灯号:264

旗子灯号收回率:23.45%匀称告成率:72.46%告成率达到50%的股票数有:85.77%

利润1总匀称:23.03%最大匀称利润1:  336.09%  最小匀称利润1:  0.00%

利润2总匀称:9.75%最大匀称利润2:  318.14%  最小匀称利润2:  -61.61%

编程思路:

VAR1赋值:1VAR2赋值:(2*收盘价+最低价+最自制+收盘价)/5VAR3赋值:34日内最自制的最低值VAR4赋值:34日内最低价的最高值VAR5赋值:收盘价的12日指数移动匀称-收盘价的26日指数移动匀称VAR6赋值:VAR5的9日指数移动匀称VAR7赋值:VAR1*收盘价*1.236<收盘价的60日俭朴移动匀称VAR8赋值:收盘价/1日前的收盘价>1.021VAR9赋值:(最低价-收盘价)*1.36<=收盘价-收盘价VARA赋值:(收盘价的120日俭朴移动匀称-收盘价)/收盘价*100VARB赋值:VAR5-VAR6的绝对于值VARC赋值:收盘价的90日估算标准差*10VARD赋值:统计5日中餍足(15日前的收盘价-收盘价)/收盘价*100>45的天数输出买:假定VAR1*VAR7ANDVAR8ANDVAR9ANDVARC<25ANDCLOSE<8ANDVARA<114ANDVARB<=0.23*40,前去55,否则前去0

公式源码:

招贤纳士 35);">VAR1:=1;VAR2:=(2*CLOSE+HIGH+LOW+OPEN)/5;VAR3:=LLV(LOW,34);VAR4:=HHV(HIGH,34);VAR5:=EMA(CLOSE,12)-EMA(CLOSE,26);VAR6:=EMA(VAR5,9);VAR7:=VAR1*CLOSE*1.236<MA(CLOSE,60);VAR8:=CLOSE/REF(CLOSE,1)>1.021;VAR9:=(HIGH-CLOSE)*1.36<=CLOSE-OPEN;VARA:=(MA(CLOSE,120)-CLOSE)/CLOSE*100;VARB:=ABS(VAR5-VAR6);VARC:=STD(CLOSE,90)*10;VARD:=COUNT((REF(CLOSE,15)-CLOSE)/CLOSE*100>45,5);买:IF( VAR1*VAR7 AND VAR8 AND VAR9 AND VARC<25 AND CLOSE<8 AND VARA<114 AND VARB<=0.23*40,55,0);

本站是供应集团知识打点的网络存储空间,全体内容均由用户宣布,不代表本站概念。请留心甄别内容中的联络要领、诱惑置办等信息,谨防诳骗。如缔造有害或侵权内容,请点击一键告发。